Back to overview
Degraded
Issues with creating and viewing certain content
Feb 16 at 01:16pm HST
Affected services
erlcx.com
Resolved
Feb 16 at 01:48pm HST
We've fixed all the issues!
Affected services
Created
Feb 16 at 01:16pm HST
We've received reports of users having difficulty creating ELS and map templates on the website. Some users also can't view YouTube videos for ELS creations. We're currently investigating these issues.
Affected services